
Spectral Analysis Software for Geoscientists since 1995

Navigating in TSG8 - Functional Overview
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• Imports reflectance spectra and images from multiple instruments

‒ Reflectance spectra from 380-15,000 nm (0.3 – 15 micrometres) 
(VNIR, SWIR, MIR, TIR)

‒ ASD, Spectral Evolution, Agilent, HyLoggers, Corescan, ENVI 
SpecLibs, ASCII

• Various levels of automated mineral interpretation with unmixing

‒ Built-in spectral reference libraries & spectral modelling tools

‒ Tools for editing & providing context & domains to those 
interpretations

• Tools for creating your own spectral indices (called Scalars in TSG)

• Multiple & vibrant visualization tools with mineralogical filters

• Handles field-sample or core images & GPS data, where they exist.

What does TSG provide? - 1
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• Imports external numerical or textual data (e.g. assays & logs)

• Exports data and images to other packages

• Downsamples to different intervals

• Advanced statistics: PCA and Cluster analysis

• Quantification tools for calibrating spectra to known analyses 

‒ (PLS modelling & prediction)

• Exports and imports between MS SQL and Oracle databases 

‒ (e.g. NVCL servers)

• Product generation, reporting, workflow management & 
housekeeping.

What does TSG provide? - 2
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Navigating in TSG8 – Top Left - Management

File                       Edit                    View              Window              Help
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Spectra from hand-held devices will 
normally be in a single package of files. 

Spectra and images from 3rd generation 
HyLoggers (HyLogger-3) will be in two 
groups of files with the VNIR/SWIR in 
one package and the TIR in another.

The two dataset packages know about 
each other and depending on which is 
active are referred to as the primary 
and associated datasets respectively.

A typical complete dual HyLogger-3 
package is shown at the right. 

TSG Data Files

ASD
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Core tray images

VNIR / SWIR Package – Open 1st

Layout files

Linescan image of core

Profilometer data file

Hole Mosaic image

TIR Package - Open later

Opening Datasets
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Navigating in TSG8 – Dataset Info

File … Dataset Info …….. Metadata ………. Description ………. TSA Summary
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Navigating in TSG8 – Layout Manager
Explore previously saved screen content, if present.

.…Click on any item to go to a saved 

set of screens showing specific 

information

Use “Manage” to 

enter, edit or view 

detailed content
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Precaution. Changing to a Layout from 

the associated dataset makes that 

dataset now the primary one. 



Navigating in TSG8 – Top Right Content Menus

Summary                                      Log                                 Spectrum

Stack                                     Scatter                                      Tray
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Navigating in TSG8 – Top Right Content Menus

Hole

Cursor position

is retained on

all screens



Types of TSG Plots
Mt Julia MJ021 

HyLogging data 

courtesy MRT 

& CSIRO

A. Histograms of classification results vs. depth (top) – Drill hole summaries

B. Per sample (dot) plots (centre) - To map mineral chemistry details

C. Histograms of other quantities (bottom) – e.g. wavelengths, assays, etc.

3 mica species populations

(i)

(ii)

(iii)

(i)(ii)(iii)

Na Fe/MgK



Types of Scatter Screen Plots

Choose the type of plot from the “Type” drop-down menu (red arrow).

Scat = per sample (dot) scatter plots

Hist = simple histograms

Hist2 = weighted histograms (as defined by ‘y’ axis scalar)

Grid = point density plots

Spec = current sample spectrum

Histogram bin size or interval is set at the blue arrow location
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Plot Type Examples
1=Hist,  2=Hist2,  3=Scat,  4=Grid,  5=Spec,  6=Scoped Hist



Scatter Screen Axes

Almost any variable can be plotted on 
TSG’s 3 scatter screen axes: 

‘X’ (commonly depth, but not necessarily)

‘Y’ any other scalar

“Aux’ the colouring variable 

Pick variables from the respective axis 
drop-down lists. These show all scalars in 
TSG, arranged in Folders. 

Try exploring these
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TSG Floater Functionality – 1 to 4 Floaters

Full 

spectra Co-

occurrence

Statistics

Context

sensitive

menu

Navigation

TSA

AuxM

Scratch

Pad

Core

Image

Tray

Image

Core

Mosaic

Maps

Feature

Frequency

Copy

Switch

Adjust

scales

This is a Floater

Line 

weight



TSG Floaters – Explore spectra, fits, images & more

All floaters share common functions: spectra from different wvl regions, images, models & more.  



TSG Floaters – Explore spectra, fits, images & maps

All floaters share common functions



Finding content will depend on how your service provider has set 
things up for you. 

The most important screens will be those highlighted at top right:

1. The Summary Screen for an initial whole-of-dataset overview of minerals

2. The Hole Screen for a further, top-down, whole drillhole strip log like view.

3. Tray Screen for exploring the detail on individual core trays

4. The Scatter Screen for detailed views of individual minerals, groups, assays, etc. 

Exploring Content   - Top Right Menu Items

1 4 3 2
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Exploring and Organising Content - Folders 

What data might be available?

All information derived from a 

spectrometer (e.g. a HyLogger), 

including images and information 

extracted from spectra, mineral 

interpretations, indices (what we 

call scalars), imported logs, 

assays, GPS locations, masks,etc., 

are stored in folders and sub-

folders (right).
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Typical Drill Hole Folder Structure & Content
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Special HyLogging Folders
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HyLogging datasets have particular 

scalars that record tray and sample 

geometry, etc., ……………………………..

Scalars can be edited & 

moved between folders 

in the Edit > Scalar names 

& Groups with right-click 

Cut & Paste functions …………



Results of automated unmixed mineral group classification / interval.

Exploring Content - Summary Screen

Try changing the interval / bin size.

(Right-click in each screen 

to activate before changing 

selections above)



With tens to hundreds of thousands of spectra in a drill hole (125 
per metre) automation is essential. 

TSG uniquely provides automated tools for unscrambling mineral 
mixtures almost always evident in spectra and modelling their likely 
mineral composition. Methods available include:
• TSA - The Spectra Assistant unmixing and labeling algorithm

• CLS - Constrained Least Squares unmixing

Both provide complementary 
facilities with different upsides 
and downsides.

Both draw on reference libraries of 
notionally pure minerals to model 
components using statistical fitting 
methods. 

None can be guaranteed to be 100% correct 100% of the time. 

Geological context and caution are always essential.

Automated Mineral Interpretation



Digression - Acronyms

1. TSG & TSG8 – The Spectral Geologist software package

2. TSA – The Spectral Assistant – Interpretation Algorithm
 sTSAS, sTSAV, sTSAT (system level TSA)  (S=SWIR, V=VNIR, T=TIR)
 uTSAS, uTSAV, uTSAT (user edited level TSA)
 dTSAS, dTSAV, dTSAT (domained TSA with restricted mineral sets [RMS])

3. CLS – Constrained Least Squares – unmixing algorithm 
 CLST, 

4. jCLST – Joint CLS algorithm using SWIR knowledge for thermal 
infrared unmixing

5. Scalars – Indices showing the depth or wavelength of an 
absorption feature, or a classification of minerals. Numeric or 
textural. 

6. Obsolete names - TSG-Pro, TSG-Core, TSG-HotCore
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1. A System-provided Global View - A Global Mineral Set (GMS)……………...

• Provides an initial guide rather than a blank sheet of paper. 

• But doesn’t know where you are!

• Doesn’t know anything about your project’s geological context

• Produces sTSAS, sTSAV, sTSAT/sjCLST results

2. A User-constrained local or drill hole view – A District Mineral Set (DMS)…..........…..

• Edited on the basis of broad-scale understanding of geological context, 

• Produces uTSAS, uTSAV, uTSAT/ujCLST results

• See TSA’s Active Mineral Lists (AML) under TSG Settings > TSA

3. An edited, within drill-hole Domain view – Restricted Mineral Set (RMS) … 

• Uses the Domain Editor. Produces a set of Domain RMS results, e.g. dTSAS

• Based on modelling the “best” and simplest fits 

• Brushed up with a summary of everything the HyLogger's told you

• CLS results are always Domained (mostly CLST) by definition.

DDH

Mineral Interpretation Context - TSG’s Hierarchical Approach



Editing Drill Hole Active Mineral Lists (AML)

Every dataset & each spectrometer needs a set of Active Minerals 
that must be edited to upgrade an unsupervised  System-level result 
to a supervised User set. Otherwise tears will results! 

Lists for the different 

spectrometers should 

ideally align



Each sub-screen can display a different interpretation - VNIR,SWIR,TIR

Exploring Content - Summary Screen
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Domains and the Domain Editor

The domain editor allows the 
user to: 

• create spectroscopic and 
mineral domains, 

• assign different mineral 
assemblages to those 
domains 

• test the fits and 

• create summary notes about 
the domains composition
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Results of automated unmixed mineral group classification / interval. 
Use right-click menu for local changes applicable to each sub-screen. Click in a sub-screen and then try making some changes.

Exploring Content - Summary Screen
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Domains, if they have been created, can be plotted by selecting the 
Ribbon Scalar (red arrow) which will appear at the yellow locations. 

Exploring Content - Summary Screen
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The Summary Screen displays normalised mineral or mineral group 
counts or weights/proportions.

Exploring Content - Summary Screen

Sampling 

interval / 

bin size 

typically 

metres

Minimum content 

per interval 

changeable from 

right-click menu

Drill hole 

name

Algorithm 

Version
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Conventional per-sample logs of numerical or class results or images.
Use right-click menu for local changes applicable to each sub-screen. Click in a log column to experiment with changes.

Exploring Content – Log Screen
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Conventional per-sample logs of numerical or class results or images.
Use right-click menu for local changes applicable to each sub-screen. Click in a log column to experiment with changes.

Exploring Content – Log Screen
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Primary dataset logs have white headings, 

Associated dataset logs have pink headings.



Exploring Content – Spectrum Screen
Individual +/- various reference library spectra (pink). Can help interpretations. 

V-lines provide movable guides. View external Aux libraries after Attaching.
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Exploring Content – Stack Screen
For examining groups of spectra to appreciate similarities or changes across 

boundaries. Use Final Mask filter to only see rock spectra. Multiple wvl options.
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Exploring Content – Scatter Screen

From 1 to 25 sub-screens controlled by X & Y “Subs” (arrowed) showing histograms, 
scatter plots, mineral classes, lithologies, assays, core colour, spectra and more. 
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Exploring Content – Scatter Screen Plot Types

Plot types (histograms, scatter plots, spectra, grids) are selected with the Type 
drop-down (yellow arrow). The current sub-screen is outlined in red (red arrow) 
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Exploring Content – Expanding Sub-screens

Double click outside the plot axes to expand current sub-screen to fill the whole 
screen. Ditto to return to the previous view. Current cursor position is preserved. 

HyLogging Workshop August 2014   |   Jon Huntington



Scatter Screen Export

Select all sub-screens or only one at yellow arrow then copy to clipboard at red arrow 
to place in another application. Use View > Save to save graphics to a file (blue arrow). 

Right-click any sub-screen to export content to a .csv file. 
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Manage screen space with Floater short-cut keys

Place or hide Floaters in any screen with <Alt+Home> or <Alt+End> to display 
left or right or toggle <CNTRL+Del to hide/restore. <CNTRL+Home> or CNTRL+End to 

display top or bottom.
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Alt+End



Exploring Content – Tray Screen
Reproduces and annotates the original core tray sample by sample. 
Can show classes, indices, assays, lith codes, etc. This is also where 

depth logging is done.  Content can be exported, plain or annotated. 
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1 2 3

Remember

pixels overlap



Exploring Content – Tray Screen

Toggle screen backgrounds between black or white on any TSG screen at red arrow. 
Copy current screen to clipboard to place in another application at yellow arrow.
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Set backgrounds for image 

saves under File > Settings



Exploring Content - Hole Screen

See an entire drill hole in 
one A4 aspect plot.

Can show images, classes, 
indices, assays, lith codes, 
etc. in a variety of styles.

Zoom-in on specific depth 
intervals for more detail.
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Creating Content – Scalar Creation Methods

New scalars are created 
from any screen under Edit 
> New Scalar from the main 
top left menu, or in the Log 
Screen, by right-clicking 
then > Edit, Add, Del. 

TSG offers a large number 
of tools for creating or 
importing new scalars and 
content. At right each is 
briefly described. 

Two of the commonest are 
the Profile method and the 
Pfit method.  

Each of these can be 
discussed and explored. 
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Modelling Absorption Feature Parameters 
Depth & Wavelength  Abundance & Composition

HyLogging Workshop August 2014   |   Jon Huntington

Using the Pfit tool to extract the depths (relative abundance) & wave-
lengths (composition) of absorption features for an entire drill hole.
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Modelling Absorption Feature Parameters 
Depth & Wavelength  Abundance & Composition
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Using the Pfit tool to extract the depths (relative abundance) and 
wavelengths (composition) of absorption features.
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Modelling Absorption Feature Parameters 
Reviewing rules and evaluating fits
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Right-click, select the ‘Y-axis scalar’ and ‘Modify’ to see to the Pfit dialogue. Review 
or edit rules or hit “Evaluate’ to see the fit. Select other samples to review their fits. 
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Importing 

The following are easily imported from spreadsheets or CSV or LAS 
files direct or via the clipboard. See main File menu. 

• Alphanumeric text data (e.g. manual logs, log codes, stratigraphy, lithology, 
XRD results etc.)

• Numeric data (e.g. GPS coordinates, assays, mag’ susc’, wireline logs, etc.)
• Reflectance spectra from field instruments or spectral libraries as ENVI-

SpecLib files or ASCII 2 column files. 
• Maps as .jpg files into the Floater maps option.
• Sample images as .jpg files from Smart phones with synchronisation tools.
• TSG can handle geochemical data without any spectral data. 
• All data once imported can be plotted.

• Imports are synchronized to depth or sample #. TSG depthsneed to be as 
good as possible. Depth logging (assignment) handled in Tray Screen.

Importing and Exporting Data
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Importing coordinates: 

• directly from instrument

• via .csv file import

• from Smart phone

User Scatter Screen as a map 
making tool, e.g.

• Eastings vs. northings 
coloured by mineralogy, or 
any other TSG variable. 

Handling GPS coordinated spatially data
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Image courtesy of Sasha Pontual 



Exporting

All data (interpretations, scalars, anything) can be 
exported to .csv files for import into other packages.

e.g. ioGas, Leapfrog, GOCAD, etc.

Exports can be at native spatial resolution or “downsampled” to 
some other interval (e.g. 1 m or to a user specified set of intervals)

 Class exports can be done “intelligently” and concatenated 

 Numeric exports can be totals or averages

All images can be exported as .jpg or .png files

Spectra can be exported to ASCII, ENVI-SpecLib or TSG files.

Importing and Exporting Data
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• Copy Processing – Use another dataset to copy process its scalar methods into 
a new dataset. Saves time and builds consistency.

• Writing Scripts and Script Libraries – Write and build libraries of batch scripts 
for undertaking routine & repetitive calculations. 

• Headless TSG – Run TSG unsupervised without any windows in the 
background taking instructions from a script.

• Computing dataset statistics (correlation and covariance structure), principal 
components and class classification (clustering).

• Partial Least Squares (PLS) for modelling relationships between spectra & say, 
XRD results or geochemistry. Quantification of TSG’s relative results.

• NVCL uploading. TSG can upload its data files into Oracle or MS SQLServer
databases for storage and then using server download tools retrieve them 
back into TSG. 

• Importing and using external spectral reference libraries.

Specialist tools not discussed today
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Acronyms

1. TSG & TSG8 – The Spectral Geologist software package

2. TSA – The Spectral Assistant – Interpretation Algorithm
 sTSAS, sTSAV, sTSAT (system level TSA)
 uTSAS, uTSAV, uTSAT (user edited level TSA)
 dTSAS, dTSAV, dTSAT (domained TSA with restricted mineral sets [RMS])

3. CLS – Constrained Least Squares – unmixing algorithm 
 CLST, 

4. jCLST – Joint CLS algorithm using SWIR knowledge to guide 
thermal infrared unmixing. Evolving

5. Scalars – Indices showing the depth or wavelength of an 
absorption feature, or a classification of minerals. Numeric or 
textual. 

6. Obsolete names - TSG-Pro, TSG-Core, TSG-HotCore
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Short-cut Keys
See under <HELP>
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Follow-on Resources - 1

1. TSG8-Viewer – Free TSG-Base version for read-only viewing of previously 
processed TSG or NVCL datasets. Available from the TSG website. 

2. TSG website for info - www.thespectralgeologist.com

3. South Australia’s SARIG site - https://sarig.pir.sa.gov.au/Map

4. Link for TSG purchase - http://bit.ly/TSG-V8

5. GMEX Minerals Guides from Ausspec International 
e: sasha.pontual@ausspec.com
t: 1300 85 44 65
w: ausspec.com

GSSA Workshop April 30th 2018   |   Jon Huntington

http://www.thespectralgeologist.com/
https://sarig.pir.sa.gov.au/Map
http://bit.ly/TSG-V8
mailto:sasha.pontual@ausspec.com
http://ausspec.com/


Follow-on Resources - 2

1. AuScope Website: http://www.auscope.org.au/

2. AuScope Portal: http://portal.auscope.org/portal/gmap.html

3. NVCL web page: http://www.auscope.org.au/site/nvcl.php

4. CSIRO HyLogging website: http://www.csiro.au/Organisation-
Structure/Flagships/Minerals-Down-Under-Flagship/Exploration/hylogging-
systems.aspx

5. GS SA HyLogging web site: 

https://sarig.pir.sa.gov.au/

6. Corstruth – Access to over 2,300 drill hole plots & Google Map interface

http://www.corstruth.com.au

7. AUSGIN from GA

http://portal.geoscience.gov.au/gmap.html
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Thank you

Feedback & questions to:

Email: jon.huntington@csiro.au , jon@hhgeoscience.com.au. 
Web: hhgeoscience.com.au 

Phone: +61 (02) 9490-8839   Mobile: +61 408-221-934

TSG and TSA, are registered trademarks of CSIRO. The HyLogging technology was developed by CSIRO 

with support from many parties, including industry, AMIRA International, MRIWA  and AuScope Pty Ltd. 

HyLogging and HyLogger are now registered trademarks of Corescan Pty Ltd. 

mailto:jon.huntington@csiro.au
mailto:jon@hhgeoscience.com.au


2018 HyLogging with TSG Workshop
Geological Survey of South Australia’s Tonsley Core Library 

Monday 30th April 2018
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1. Learn how to objectively create valuable mineralogical and 
geological logs of drill-core from hyperspectrally-scanned and 
imaged cores and chips using the TSG8 software package on 
HyLogging data.

2. Learn how to import external data to analyse alongside the 
HyLogged mineralogy and imagery and export into other 
packages. 

3. Learn how to access publically available drill core data and 
understand what has been done to it and how it can be used 
independently. 

4. Take away records in MS Word or PowerPoint of your own logs 
created using TSG8.

Workshop Goals
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1. In the Layout lab, familarise yourselves with drillhole geology, in 
particular, primary versus alteration mineralogy. 

2. Address a series of questions relevant if logging this drillhole, e.g. 

a. where is the base of weathering? 

b. what is the mineralogy of the skarn? 

c. what are the alteration minerals in the igneous units? 

3. These questions should be investigated further when working with 
the spectral data throughout the day.

4. Record your observations by core tray number and depth. Take 
photos if it helps to jog your memory later

5. Make use of your hand-lens, scribe, magnet and acid bottle 
(provided in the lab).

Task 1 – Core Familiarisation
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1. Open the provided TSG dataset MSDP11.tsg 
(not MSDP11_tir.tsg)

2. Follow-along with guided tour from the 
speaker 

3. This task is primarily about navigating TSG’s 
options not geology 

4. Use provided, more detailed, PDF presentation 
as a reference guide where necessary. 

Task 2 – Basic TSG Navigation
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1. In Summary Screen & then, more importantly, the Scatter Screen examine sTSA 
results & note what might be correct / incorrect

2. Using histograms of abundance (use right-click > Standard Setup in Scatter 
screen > System TSA) examine & note down low abundance or unlikely minerals. 
Maximise all ‘Y’ scales with right-click > Scaling Extras > Auto Scale 
all > Y on.

 Use Floaters to check for, a) believable fits or, b) core images to check on edges. 

3. Edit Active Minerals Lists (File > Settings > TSA) to exclude noted errors of 
commission & stupid (incompatible) results for VNIR, SWIR & TIR). Check “Mark 
for re-calc” at each stage. Wait for TSA to re-run

4. Once re-run visit Summary Screen, Log Screen and Scatter Screen and assign all 
displays of interps to uTSAS & uTSAT respectively. Optionally do the same to the 
Tray Screen using the right-click Standard Layout options. 

5. Understand Aspectral distribution & compute  RelRange scalar. 

Task 3 – Refining Initial Mineral Interps
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1. In Summary Screen (make Bin=2m) 
recognise homogenous mineralogical 
assemblages & using Domain Editor (D) 
[1] at right create new Domains [2] for 
entire hole from top to bottom. 

2. For each Domain place cursor where you 
want a boundary. Consider both SWIR & TIR 
plots. Hit “New” in Domain Editor then 
“Proceed”. Domain will appear in Ribbon [3]. 
Repeat throughout hole.

3. For last domain partially fill then choose > Fill 
below [4].

4. On completion select Auto TSA [5] in Domain 
Editor to assign initial Restricted Mineral Sets 
(RMS) for each Domain.

5. Note main minerals are added to each Domain 
description. Add Domain names for reference.

6. We will discuss how to edit Domains.

Task 4 - Build Domains 1

2

3

2
4

5



uTSAT has only done mineral mix=3, partly because of speed.
We will need to go deeper 

Calculate CLS scalar set with mix=6 

1. Go “Edit” > “New Scalar”

2. Pick the TIR file [1] as we are 
unmixing the TIR data

3. Choose method = CLS [2]

4. Provide a name for scalar [3] and 
hit “Next”

5. Fill out as opposite considering 
the various options, then “Finish” 

Task 5 – TIR Constrained Least Squares (CLS)
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We can check if the correct restricted mineral sets (RMS) have been 
selected for each Domain by looking at the Residuals to the fits. 

1. On the Log Screen use the 
blue “Go to” button to move 
to Sample/Index #49737. 

 Did you see the garnets in the core this morning? 

2. Select a Floater with TIR spectra in TSA mode

 Note its good fit to garnet 

 Choose Constrained Least Squares from the right-click Floater menu and 
turn on “From Domain”

3. Select the Domain Editor and then Edit then TIR

 Your screen should look like the next page ……

Task 6a - CLS Residuals
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Task 6b - CLS Residuals
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Note the garnet selections 

& the good model above

Next turn off the garnet in the right-hand 

RMS selection list then hit Update

N
O



Task 6c - CLS Residuals
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Note the poor model above 

& the high residuals in the 

Log Screen. Discuss

Before leaving turn the garnet on again 

then hit “Update” (starred).

So the idea is to check for & 

explain these high residual patterns

*



So the CLS residual tool allows us to check each Domain for mineral 
spectra we may have missed. 

High residuals occur due to:

a. missed mineral spectra not allocated to a Domain

b. minerals not in the reference library

c. volume scattering effects, cracks and edges

Another way to view residuals is to plot the CLS Error scalar in a 
Scatter plot vs. depth & interrogate high values.

Use the “Go to” button and choose Index sample #56589

Using the TIR Floater in CLS mode & explain the high residuals there. 
The screen may look like the next page ….

Task 6d - CLS Residuals
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Task 6e - CLS Residuals
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Should quartz be included?

Explore adding other 

mineral spectra

Discuss how to deal with this 

poorly fitting interval



Indices of the depth & wavelength of absorption features provide a powerful 
characterisation of the data and can be used as proxies for abundance & composition 
respectively. They also help Domaining. TSG provides many ways of making scalars. 
FeatEx is one. 

TSG keeps tables of all absorption Feature wavelengths in each spectrum. The FeatEx 
method allows us to extract & plot them.

1. Go Edit > New scalar > and copy these dialogues

2. Repeat but calculate the Wavelength (wvl) as the Name, the Slot = New & 
Wavelength as the Feature parameter. Keep other parameters the same.

3. Duplicate 1st wvl, change Name & Slot & Second deepest in the 2nd dialogue box. 

Task 7a – Building Simple Scalars



In the Scatter Screen now plot these three FeatEx scalars, as follows so 
as to produce three plots like the next page. .

Task 7b – 1400 nm Feature Scalars
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Note the patterns vs. depth & how different minerals & mineral mixtures
appear at different wavelengths & depths in the hole. Use Floaters to 
check spectra & features. Do implied Domains match earlier ones? 

Task 7c – 1400 nm Feature Scalars



This idea can be repeated for the 2350nm region where mixtures make 
tracking overlapping wvls difficult. Make a 2350+/-60 FeatEx wvl scalar 
then plot a) vs. depth and b) vs. the earlier 1440+/-60 scalar.

Task 7d – 2350 nm Feature Scalars

a

b



Now right-click in bottom screen & use the “Class Browse Edit” tool with Lasso 
option active to highlight different clusters & note where they plot spatially. Are 
all the amphiboles (pink) the same?  Note Domains. Do you need to add new 
ones?

Task 7e – 2350 nm Feature Scalars



Sometimes you need to map the characteristics of quite specific 
features in a spectrum and search for those throughout a whole drill 
hole. TSG provides the Profile and Pfit methods for this. 

Here we use the Pfit method to map the relative abundance and 
composition from all spectra in the drill hole. We use a carefully 
constrained and thresholded polynomial fit to all spectra to very 
accurately extract depth and wavelength information. 

• The thresholds (blue arrow overleaf) are critical to this process 
and are  to detection limits & thresholds in geochemistry. 

On the previous page we found variation in the Amphiboles. This 
example attacks the 1393nm absorption feature’s characteristics by 
creating two related depth and wavelength scalars.

1. Go Edit > New scalar > Method = Pfit. 

2. Give your scalars names and a folder location as per the following 
page. 

Task 7f – Building Complex Scalars



Create these scalars and then we can discuss the meaning of the 
various parameters and explore the evaluate button (arrowed).

Task 7g – Polynomial Fitted Scalars



Your results should look like this in the Scatter Screen. From this you’ll see that 3 
minerals (actinolite, talc, serpentine) with very sharp 1393 features have been 
mapped, but with slightly different characteristics, occurring within the 1 Domain.

Task 7h – Polynomial Fitted Scalars

Feature wvl

Feature depth



TSG provides several suites of built-in and attachable scalar-creation 
scripts. 

• Go Edit > New > Method = Batch. 

From here you can select the top right-hand drop-down of options 
of System provided scripts … 

…. or load scripts from an external file source. TSG provides several 
with each installation. We will handout some thermal IR examples. 

TSG’s Built-in Scalar Scripts - 1
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Built-in scripts in TSG8 have changed since earlier versions.

So called “Base” script names (below) are brief with names that use a 
convention of D for feature depth (often a proxy for abundance) and 
W for wavelength (often a proxy for composition) preceded by a 
wavelength in nanometres.

Once selected an info’ box links to a table of use explanations while 
selecting the Edit button brings 
up the Script’s text which can 
be viewed or edited. 

Note most of these scripts have 
no thresholds set & may thus 
include garbage. This can be 
changed if the minval = 0 is 
present. 

TSG’s Built-in Scalar Scripts - 2
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Some of the most 
frequently valuable  
scalars are those to track 
the abundance and 
composition of any white 
micas or chlorite / 
epidote / biotite minerals 
present. 

Giving each new scalar 
an appropriate name 
try these, 

A) for W-mica/Smectite

B) for Chl/Epi/Biot
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Task 7i – W-Mica + Chl/Epi/Biot Scalars

A

B



1. Does magnetite have a spectral signature at any wavelength in our 
datasets?

2. Use the provided AuxM reference spectrum to search for 
magnetite, just in case

3. Compute a fit to this reference 
with the AuxM scalar method 
using the dialogues opposed

4. Plot the scalar in a Scatter Screen 
sub-screen using the Scat mode 
& colour it by the same scalar. 
AuXM scalars will be found in 
the “Assemblages & AuxMatch” 
folder

5. The initial AuxM scalar has a 
score cut-off = 0. Modify this 
scalar to place a cut-off at a 
more valuable threshold such as ?

6. Discuss options & results.

Task 7j – Using AuxMatch



We can attach Aux spectra of any TSG compatible files for reference & 
visualization purposes. Here’s how …..

1. On the Spectrum Screen go File > Attach Aux and then, for 
example, select the “Highest Mag Susc …” file from your disk. 

2. Then go File > Settings > Aux. You will
be presented with the dialogue 
opposite. We’ll discuss this. 

3. Note it is important that the settings 
in here match those used previously 
or subsequently in any AuxM scalar for 
consistent results. We’ll discuss

4. AuxM results can be viewed 
in Floaters or the Spectrum 
Screen by selecting Aux or 
the Aux symbol (red arrow). 

Task 7k – Attaching Aux Files



Because the TIR involves many more minerals and mixtures it is less 
easy to devise scalars to parameterise individual absorptions. 
However a few generic scalars will be found to be very valuable. 
Your tasks are:

1. Find the built-in TIR batch scripts.

2. Calculate TIR Felsic-Mafic Index (FMI) & review purpose & value. 

3. Display TIROffset & with imagery explain what it maps. 

4. Calculate the four carbonate scalars and the two silica Scripts 
provided in the Batch Scripts. Results will be placed in their 
respective mineral folders.  

Task 8a – Thermal Infrared Scalars
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A suite of thermal infrared scalars were developed by Martin Schodlok 
and Jon Huntington in ~2011. Updated these are now provided as 
built-in User Batch Scripts for routine use in TSG8. See memory sticks

1. Open the MSDP11 TIR dataset

2. Go Edit > New Scalar > Batch > Next > File > Pick > Sub-Directory

3. Then pick the “FMI” or other script from the drop-down list.

Task 8b – Thermal Infrared Scalars
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Task 8c - The FMI Rationale - Recap
(Traditionally only applied to igneous rocks but works well on many other rock types and minerals)

Minerals

Felsic granite

Granodiorite

Monzonite

Gabbro

Norite

Dunite

Picrite

Rocks



Task 8d - The Felsic Mafic Index (FMI) recap

The FMI (an empirical alternative to the 
published “Christiansen Frequency1”) 
tracks not the CF minimum wvl but the 
wvl of the overall peak reflectance curve 
between 7,800 & 12,000 nm computed 
with a 4th order polynomial (bottom 
right). Such an Index is very useful for 
differentiating dominantly Felsic vs. Mafic 
vs. Ultramafic lithologies. 

Additionally we mask out any carbonate 
bearing samples using their reflectance 
peak at 6500 nm as carbonates have less 
bearing on the felsic / mafic nature of a 
lithology and also distort the computation 
of the true felsic / mafic mineralogy.

CF

Pure quartz

The modelling shown involves inverting the spectrum (black) 

and fitting the low order polynomial (orange) to determine the 

curve’s inverted peak wvl. This wvl is then reported & plotted.

1 Logan, Hunt, Salisbury & Balsamo, JGR Vol.78, No.23, 1973, 

Compositional Implications of Christiansen Frequency Maximums 

for Infrared Remote Sensing Applications. 
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Task 8d - MSDP11 Felsic Mafic Index
Your FMI pattern should look like this below. The top plot is coloured by mapped “Strat_ 

Name”) and the bottom smoothed version by the dominant CLS TIR mineralogy. Note all 

the correlations & possible disagreements where new units / Domains may be required. 

Does this help your characterisation and subdivision of this drill hole?



In the TIR dataset’s HyLogging folder is a system scalar called TIRBkgOffset. It is 
one of several background terms used in the modelling of mineral spectra. 

• Display it and with the imagery in a Floater examine what it is telling you 
and why? Use Scope = Mask. Let’s discuss. 

What does the TIRBkgOffset Scalar Tell You?
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Scope = Mask(Final Mask);  54513 Points, r=0.0245;  Aux: TirBkgOffset
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You can compute your own better equivalent of the TIRBkgOffset with this 
scalar below. Try it, display it and examine its value in the overall 
characterisation of the drill hole. Are there geological and non-geological 
things that influence this scalar?

• Go Edit > New Scalar > Choose TIR dataset > copy dialogues below

What does the TIRBkgOffset Scalar Tell You?

• Add to your drill hole report if you think it’s useful and briefly explain why
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Generally the TIR is better at mapping Carbonates than the SWIR due 
to less overlap of features. Using the provided Batch Scripts on the 
memory sticks create the five Carbonate scalars (below) then display 
them in the Scatter Screen 

1. Open the MSDP11 TIR dataset
2. Go Edit > New Scalar > Batch > Next > File > Pick > Sub-Directory
3. Then pick each of the CO3 scripts in turn and run them
4. Let’s discuss the results.

Task 8e – TIR Carbonate Scalars
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TIR reference spectra of several oxides (e.g. hematite, limenite, 
magnetite) show very modest amplitude features, however they do 
exhibit consistence slopes: hematite a negative slope, magnetite a 
positive slope. 

We can take advantage of this in TSG and compute a slope scalar that 
will illustrate this. See next page. 

Caution: Non-ambient temperature effects can also impose slopes.

Task 8f – TIR Magnetite Scalar
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TIR magnetite spectra with the strong positive slopes commonly 
pair with the SWIR magnetite spectral shapes discussed previously 
(see below left).  The scalar above when computed for MSDP11 or 
WRD33 will enhance many magnetite bearing samples / intervals. 

Task 8g – TIR Magnetite Scalar
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• Using two input scalars and the arithmetic method compute 14250 

NormRef minus 6100 NormRef. Interrogate the resulting plot with 

TIR & SWIR Floaters and an image. Is the magnetite obvious?



1. Set up the Summary Screen to show uTSAS and uTSAT results and 
compare. 

2. Set up the Summary Screen to show uTSAT and CLST results and 
compare. 

3. Can you build in series of Scatter Screens that best show the 
dominant SWIR and TIR minerals, the best scalars and the Domains 
as a summary of everything you’ve learnt. 

4. Cut and Paste the best of these into your Word or PowerPoint 
Report. 

5. Feel free to write a few words as to your conclusions.

Task 9 – Comparing uTSA, CLST and Scalars 
to help build your report 
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Find the Geological Logs and Assays provided. It does not matter that 
the incoming data is on a different sampling interval to the HyLogging 
data. The incoming data will be resampled to match.

1. Go Edit > New Scalar > Method = Assay…… > Next

2. Import from a file source or from the clipboard. 

Note this type of input requires a “From depth” and a “To depth” 

3. Consider how you will display some of this data in the Scatter 
Screen to match some spectral results, e.g. Depth vs. Assay in 
Scat or Hist mode along with some spectral results?

Task 10 – Importing External Data
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Your can export graphics from most screens. Your can also export data in csv format 
for many screens.  The main place to export data for other packages is via the File > 
Export options. Results data can concatenated into larger intervals (Downsampled) 
to new intervals. Downsampling can be done in many ways including by sample 
number or depth. 

1. Choose File > Export > 
Downsample and explore 
the options. 

2. You should also export your 
Domain Summaries from the 
Domain Editor for import 
into Excel. 

Task 11 – Exporting TSG Data



Task 12 – Create a Report of Your Logs in 
Word or PowerPoint
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Task 13 – Accessing publically available 
datasets
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GS SA HyLogging web site: https://sarig.pir.sa.gov.au/

AuScope Website:  http://www.auscope.org.au/

AuScope Portal:  http://portal.auscope.org/portal/gmap.html

Corstruth – Over 2,300 drill hole plots, Google Map interface + analytics

http://www.corstruth.com.au

NVCL web page:  http://www.auscope.org.au/site/nvcl.php

AUSGIN from GA: http://portal.geoscience.gov.au/gmap.html

Corescan HyLogging :  http://www.corescan.com.au/news/corescan-and-csiro-

sign-a-technology-alliance-for-the-future-development-of-hylogger-and-tsg 

https://sarig.pir.sa.gov.au/
http://www.auscope.org.au/
http://portal.auscope.org/portal/gmap.html
http://www.corstruth.com.au/
http://www.auscope.org.au/site/nvcl.php
http://portal.geoscience.gov.au/gmap.html
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